summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-03 23:24:16 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-03 23:24:16 +0100
commitb8c35278285cd987732236c22cf8cdba7deae105 (patch)
tree8bda0fac98ae6ab8b0a593d1744d06736842904b /gnu
parent64a967cc9c4563f8ebb8dbc34e9026f8e5e2d883 (diff)
downloadgnu-guix-b8c35278285cd987732236c22cf8cdba7deae105.tar
gnu-guix-b8c35278285cd987732236c22cf8cdba7deae105.tar.gz
gnu: recutils: Upgrade to 1.6.
* gnu/packages/recutils.scm (recutils): Upgrade to 1.6. Add cURL and libgcrypt as inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/recutils.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/recutils.scm b/gnu/packages/recutils.scm
index f9c15d332c..2a3f09b2fd 100644
--- a/gnu/packages/recutils.scm
+++ b/gnu/packages/recutils.scm
@@ -24,27 +24,31 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages emacs)
#:use-module (gnu packages check)
- #:use-module (gnu packages algebra))
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages gnupg))
(define-public recutils
(package
(name "recutils")
- (version "1.5")
+ (version "1.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/recutils/recutils-"
version ".tar.gz"))
(sha256
(base32
- "1v2xzwwwhc5j5kmvg4sv6baxjpsfqh8ln7ilv4mgb1408rs7xmky"))
- (patches
- (list (search-patch "diffutils-gets-undeclared.patch")))))
+ "0dxmz73n4qaasqymx97nlw6in98r6lnsfp0586hwkn95d3ll306s"))))
(build-system gnu-build-system)
- (inputs `(;; TODO: Enable optional deps when they're packaged.
- ;; ("curl" ,(nixpkgs-derivation "curl"))
- ("emacs" ,emacs)
- ("check" ,check)
- ("bc" ,bc)))
+ (native-inputs `(("emacs" ,emacs)
+ ("bc" ,bc)))
+
+ ;; TODO: Add more optional inputs.
+ ;; FIXME: Our Bash doesn't have development headers (need for the 'readrec'
+ ;; built-in command), but it's not clear how to get them installed.
+ (inputs `(("curl" ,curl)
+ ("libgcrypt" ,libgcrypt)
+ ("check" ,check)))
(synopsis "Manipulate plain text files as databases")
(description
"Recutils is a set of tools and libraries for creating and