summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:44:44 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:46:23 +0000
commit9deb6c6ee0c6ab428dc280428fc8b7ea514f415a (patch)
tree4af9c086a9f26788e7e21c56f62b4137a80a5aba /gnu
parentead7b144a56c7cda1687abf7b6d383edc1529fcd (diff)
downloadgnu-guix-9deb6c6ee0c6ab428dc280428fc8b7ea514f415a.tar
gnu-guix-9deb6c6ee0c6ab428dc280428fc8b7ea514f415a.tar.gz
gnu: Improve ruby-hashie.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm50
1 files changed, 38 insertions, 12 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6f2bc73baa..677d39800d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6573,21 +6573,47 @@ is compatible with stylesheets designed for pygments.")
(define-public ruby-hashie
(package
(name "ruby-hashie")
- (version "3.6.0")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "hashie" version))
- (sha256
- (base32
- "13bdzfp25c8k51ayzxqkbzag3wj5gc1jd8h7d985nsq6pn57g5xh"))))
+ (version "3.5.7")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The gem does not include Gemfile.
+ (uri (string-append "https://github.com/intridea/hashie/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00afsf591jj1q7j44fswwwrki01qgxa6wnqi6a6sq3bfjm1jlxy6"))))
(build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-dependencies
+ (lambda _
+ (substitute* "Gemfile"
+ ((".*pry.*") "")
+ ((".*guard.*") "")
+ ((".*codeclimate.*") "")
+ (("rubocop.*") "rubocop'\n")
+ (("rspec-core.*") "rspec-core'\n"))
+ (substitute* "spec/spec_helper.rb"
+ ((".*pry.*") ""))
+ #t)))))
(native-inputs
- `(("bundler" ,bundler)))
- (arguments `(#:tests? #f)); FIXME: Could not locate Gemfile or .bundle/ directory
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-rspec-pending-for" ,ruby-rspec-pending-for)
+ ;("ruby-guard" ,ruby-guard)
+ ;("ruby-guard-rspec" ,ruby-guard-rspec)
+ ("ruby-activesupport" ,ruby-activesupport)
+ ("ruby-rubocop" ,ruby-rubocop)))
+ (synopsis
+ "Hashie is a collection of classes and mixins that make hashes more powerful.")
+ (description
+ "Hashie is a collection of classes and mixins that make hashes more powerful.")
(home-page "https://github.com/intridea/hashie")
- (synopsis "Extensions to Ruby Hashes")
- (description "Hashie is a collection of classes and mixins that make Ruby
-hashes more powerful.")
(license license:expat)))
(define-public ruby-heredoc-unindent