summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-01-02 16:52:14 +0100
committerLeo Famulari <leo@famulari.name>2018-01-04 12:44:03 -0500
commit965ced9c04c6f4801bf2e3d1d64a3607ce4852b1 (patch)
tree2122a84c9749f74e5b0b1891b40c5197df471b3a /gnu
parentdef8a62f627d00503e1fb84ac335cfa3d95a0438 (diff)
downloadgnu-guix-965ced9c04c6f4801bf2e3d1d64a3607ce4852b1.tar
gnu-guix-965ced9c04c6f4801bf2e3d1d64a3607ce4852b1.tar.gz
gnu: Add python2-pyro.
* gnu/packages/python.scm (python2-pyro): New public variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 832afe8356..849fa526b1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12180,3 +12180,32 @@ such as figshare or Zenodo.")
(define-public python2-semver
(package-with-python2 python-semver))
+
+(define-public python2-pyro
+ (package
+ (name "python2-pyro")
+ (version "3.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Pyro" version))
+ (file-name (string-append "Pyro-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0y75wzdqbjy565rpxaxscav4j8xg060sa90lnmb7aypgaf251v8v"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Pyro is not compatible with Python 3
+ `(#:python ,python-2
+ ;; Pyro has no test cases for automatic execution
+ #:tests? #f))
+ (home-page "http://pythonhosted.org/Pyro/")
+ (synopsis "Distributed object manager for Python")
+ (description "Pyro is a Distributed Object Technology system
+written in Python that is designed to be easy to use. It resembles
+Java's Remote Method Invocation (RMI). It has less similarity to CORBA,
+which is a system and language independent Distributed Object Technology
+and has much more to offer than Pyro or RMI. Pyro 3.x is no
+longer maintained. New projects should use Pyro4 instead, which
+is the new Pyro version that is actively developed.")
+ (license license:expat)))