summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEthan R. Jones <ethanrjones97@gmail.com>2018-02-05 17:55:34 -0500
committerLeo Famulari <leo@famulari.name>2018-02-05 18:04:34 -0500
commit956ba99cb799889e0a0bc0f657f4e31b4f830775 (patch)
tree04f193d24769e2fbaa04b145fd9e35cf452a9489 /gnu
parent26ecbaf8661a7aaa9ee0b94b83b81160a065ccb0 (diff)
downloadgnu-guix-956ba99cb799889e0a0bc0f657f4e31b4f830775.tar
gnu-guix-956ba99cb799889e0a0bc0f657f4e31b4f830775.tar.gz
gnu: Add python-gyp.
* gnu/packages/python.scm (python-gyp, python2-gyp): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9483ad6b1b..b45d89932d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
+;;; Copyright © 2018 Ethan R. Jones <ethanrjones97@gmail.com
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -12417,3 +12418,35 @@ style guide, even if the original code didn't violate the style guide.")
(define-public python2-yapf
(package-with-python2 python-yapf))
+
+(define-public python-gyp
+ (let ((commit "5e2b3ddde7cda5eb6bc09a5546a76b00e49d888f")
+ (revision "0"))
+ (package
+ (name "python-gyp")
+ ;; Google does not release versions,
+ ;; based on second most recent commit date.
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ ;; Google does not release tarballs,
+ ;; git checkout is needed.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://chromium.googlesource.com/external/gyp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fr7nxcrk292djmxzpcjaphnsd123k31gp8jnd91vwknhq6snmv9"))))
+ (build-system python-build-system)
+ (home-page "https://gyp.gsrc.io/")
+ (synopsis "GYP is a Meta-Build system")
+ (description
+ "GYP builds build systems for large, cross platform applications.
+It can be used to generate XCode projects, Visual Studio projects, Ninja build
+files, and Makefiles.")
+ (license license:bsd-3))))
+
+(define-public python2-gyp
+ (package-with-python2 python-gyp))