summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-02 12:49:12 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit861748efd6406b9436630cf23a498865395bf9f2 (patch)
tree1e0d4e00317b54cd79313152a02a495bf26373e9 /gnu
parent5c913ba159e285efb096c784473ababd15c233b0 (diff)
downloadgnu-guix-861748efd6406b9436630cf23a498865395bf9f2.tar
gnu-guix-861748efd6406b9436630cf23a498865395bf9f2.tar.gz
gnu: kwindowsystem: Update to 5.24.0.
* gnu/packages/kde-frameworks.scm (kwindowsystem)[uri]: Use mirror. [native-inputs]: Make extra-cmake-modules a native-input. [inputs]: Replace qt dependency with qtbase and qtx11extras.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 838bdb39c9..b338555944 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -69,27 +69,29 @@ common build settings used in software produced by the KDE community.")
(define-public kwindowsystem
(package
(name "kwindowsystem")
- (version "5.21.0")
+ (version "5.24.0")
(source
(origin
(method url-fetch)
- (uri (string-append "http://download.kde.org/stable/frameworks/"
+ (uri (string-append "mirror://kde/stable/frameworks/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "13lfwpw5a4in0mp5y8d15jg6xhhrka2qmw73wrdzcvj22n6ldzzi"))))
+ "0w5ym8msl80v3q65253pdpj9f1fmb658rnndlbkrgpmm1rv1n6dz"))))
(build-system cmake-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)
("xorg-server" ,xorg-server))) ; for the tests
(inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("libxrender" ,libxrender)
- ("qt" ,qt)
+ `(("libxrender" ,libxrender)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
("xcb-utils-keysyms" ,xcb-util-keysyms)))
(arguments
- `(#:tests? #f)) ; FIXME: The first seven tests fail with "Exception".
+ `(#:tests? #f)) ; FIXME: 8/10 tests fail.
(home-page "https://community.kde.org/Frameworks")
(synopsis "KDE access to the windowing system")
(description "KWindowSystem provides information about and allows