summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-10-31 08:12:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-10-31 08:17:06 +0100
commit7bf59f702179173055853fa940ae72292cd65a4e (patch)
tree349f6eb123a313f9e1bad83e8afc8056165d6b85 /gnu
parentb275cd22d47a42098f465ca30aee24fdc6e23826 (diff)
downloadgnu-guix-7bf59f702179173055853fa940ae72292cd65a4e.tar
gnu-guix-7bf59f702179173055853fa940ae72292cd65a4e.tar.gz
gnu: Remove cufflinks.
Cufflinks includes essential non-free code. Fixes <https://bugs.gnu.org/28946>. * gnu/packages/bioinformatics.scm (cufflinks): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm58
1 files changed, 0 insertions, 58 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index acf689d07a..53311346ca 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1836,64 +1836,6 @@ files between different genome assemblies. It supports most commonly used
file formats including SAM/BAM, Wiggle/BigWig, BED, GFF/GTF, VCF.")
(license license:gpl2+)))
-(define-public cufflinks
- (package
- (name "cufflinks")
- (version "2.2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://cole-trapnell-lab.github.io/"
- "cufflinks/assets/downloads/cufflinks-"
- version ".tar.gz"))
- (sha256
- (base32
- "1bnm10p8m7zq4qiipjhjqb24csiqdm1pwc8c795z253r2xk6ncg8"))))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags
- (list
- ;; The includes for "eigen" are located in a subdirectory.
- (string-append "EIGEN_CPPFLAGS="
- "-I" (assoc-ref %build-inputs "eigen")
- "/include/eigen3/")
- ;; Cufflinks must be linked with various boost libraries.
- (string-append "LDFLAGS="
- (string-join '("-lboost_system"
- "-lboost_serialization"
- "-lboost_thread"))))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-search-for-bam
- (lambda _
- (substitute* '("ax_bam.m4"
- "configure"
- "src/hits.h")
- (("<bam/sam\\.h>") "<samtools/sam.h>")
- (("<bam/bam\\.h>") "<samtools/bam.h>")
- (("<bam/version\\.hpp>") "<samtools/version.h>"))
- #t)))
- #:configure-flags
- (list (string-append "--with-bam="
- (assoc-ref %build-inputs "samtools")))))
- (inputs
- `(("eigen" ,eigen)
- ("samtools" ,samtools-0.1)
- ("htslib" ,htslib)
- ("boost" ,boost)
- ("python" ,python-2)
- ("zlib" ,zlib)))
- (home-page "http://cole-trapnell-lab.github.io/cufflinks/")
- (synopsis "Transcriptome assembly and RNA-Seq expression analysis")
- (description
- "Cufflinks assembles RNA transcripts, estimates their abundances,
-and tests for differential expression and regulation in RNA-Seq
-samples. It accepts aligned RNA-Seq reads and assembles the
-alignments into a parsimonious set of transcripts. Cufflinks then
-estimates the relative abundances of these transcripts based on how
-many reads support each one, taking into account biases in library
-preparation protocols.")
- (license license:boost1.0)))
-
(define-public cutadapt
(package
(name "cutadapt")