summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-22 18:28:20 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 21:31:36 +0200
commit54b83f0e899227e6bf584fbe69cb9b65fee0de2e (patch)
tree0974f3476fefc51992b39a2ed56b47dfe226a789 /gnu
parentb4d1440f9f0ed5d87ba051191a35843702841415 (diff)
downloadgnu-guix-54b83f0e899227e6bf584fbe69cb9b65fee0de2e.tar
gnu-guix-54b83f0e899227e6bf584fbe69cb9b65fee0de2e.tar.gz
gnu: Add go-gitlab-com-ambrevar-damerau.
* gnu/packages/golang.scm (go-gitlab-com-ambrevar-damerau): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 96e40bbd0a..8ad2ec943e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2171,3 +2171,31 @@ anyways and Go regexps are more powerful.")
when provided with a valid relative path / alias path, it will return you with
a string of its real absolute path in the system.")
(license license:bsd-style))))
+
+(define-public go-gitlab-com-ambrevar-damerau
+ (let ((commit "883829e1f25fad54015772ea663e69017cf22352")
+ (revision "0"))
+ (package
+ (name "go-gitlab-com-ambrevar-damerau")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://gitlab.com/ambrevar/damerau")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b9p8fypc914ij1afn6ir346zsgfqrc5mqc1k3d53n4snypq27qv"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "gitlab.com/ambrevar/damerau"))
+ (home-page "https://gitlab.com/ambrevar/damerau")
+ (synopsis "Damerau-Levenshtein distance for Golang")
+ (description "This is a spelling corrector implementing the
+Damerau-Levenshtein distance. Takes a string value input from the user.
+Looks for an identical word on a list of words, if none is found, look for a
+similar word.")
+ (license license:expat))))