summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-23 20:39:57 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-23 20:39:57 +0200
commit53142109a06155980397514795d9a36afb418f54 (patch)
tree3e4920533cbc9d1e6f8587a7bcbd0b0b5edcfe69 /gnu
parent2e88d113aac31dbea0b998fca92b35dbfc998872 (diff)
downloadgnu-guix-53142109a06155980397514795d9a36afb418f54.tar
gnu-guix-53142109a06155980397514795d9a36afb418f54.tar.gz
gnu: bluez: Install the library and header files.
* gnu/packages/linux.scm (bluez)[arguments]: Add --enable-library to #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 26e9aa9000..62a19f5332 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -308,7 +308,7 @@ It has been modified to remove all non-free binary blobs.")
(license gpl2)
(home-page "http://www.gnu.org/software/linux-libre/"))))
-
+
;;;
;;; Pluggable authentication modules (PAM).
;;;
@@ -354,7 +354,7 @@ be used through the PAM API to perform tasks, like authenticating a user
at login. Local and dynamic reconfiguration are its key features")
(license bsd-3)))
-
+
;;;
;;; Miscellaneous.
;;;
@@ -1582,7 +1582,7 @@ from the module-init-tools project.")
;; Work around undefined reference to
;; 'mq_getattr' in sc-daemon.c.
"LDFLAGS=-lrt")
- #:phases
+ #:phases
(alist-cons-before
'build 'pre-build
;; The program 'g-ir-scanner' (part of the package
@@ -2203,7 +2203,8 @@ applications.")
(arguments
'(#:configure-flags
(let ((out (assoc-ref %outputs "out")))
- (list "--disable-systemd"
+ (list "--enable-library"
+ "--disable-systemd"
;; Install dbus/udev files to the correct location.
(string-append "--with-dbusconfdir=" out "/etc")
(string-append "--with-udevdir=" out "/lib/udev")))))