summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-25 19:27:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-03-25 21:41:26 +0200
commit45f762ee968ff684107fb08f407bbea5e5852449 (patch)
treefbbe1a84636b0d2774735523cd39a0232f0255ef /gnu
parenta667d20e9a7a7ca9d9b9d96efacb4da406439937 (diff)
downloadgnu-guix-45f762ee968ff684107fb08f407bbea5e5852449.tar
gnu-guix-45f762ee968ff684107fb08f407bbea5e5852449.tar.gz
gnu: Add classpath-bootstrap.
* gnu/packages/java.scm (classpath-bootstrap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f226a69846..882a8b462e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -215,6 +215,49 @@ etc.). SableVM is no longer maintained.
This package provides the virtual machine.")
(license license:lgpl2.1+)))
+;; This is the last version of GNU Classpath that can be built without ECJ.
+(define classpath-bootstrap
+ (package
+ (name "classpath")
+ (version "0.93")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/classpath/classpath-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0i99wf9xd3hw1sj2sazychb9prx8nadxh2clgvk3zlmb28v0jbfz"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "JAVAC="
+ (assoc-ref %build-inputs "jikes")
+ "/bin/jikes")
+ "--disable-Werror"
+ "--disable-gmp"
+ "--disable-gtk-peer"
+ "--disable-gconf-peer"
+ "--disable-plugin"
+ "--disable-dssi"
+ "--disable-alsa"
+ "--disable-gjdoc")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-data
+ (lambda _ (zero? (system* "make" "install-data")))))))
+ (native-inputs
+ `(("jikes" ,jikes)
+ ("fastjar" ,fastjar)
+ ("libltdl" ,libltdl)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://www.gnu.org/software/classpath/")
+ (synopsis "Essential libraries for Java")
+ (description "GNU Classpath is a project to create core class libraries
+for use with runtimes, compilers and tools for the Java programming
+language.")
+ ;; GPLv2 or later, with special linking exception.
+ (license license:gpl2+)))
+
(define ant-bootstrap
(package
(name "ant-bootstrap")