summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-13 06:23:51 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-13 13:15:47 +0100
commit4168ddf689b3b7a176afd08c2c924f8e7ebb8c20 (patch)
treeeebb2ddac4299e747776fd312efdb7c130e72098 /gnu
parent57202f2e24e0770808d4661c5610132ef9d9b692 (diff)
downloadgnu-guix-4168ddf689b3b7a176afd08c2c924f8e7ebb8c20.tar
gnu-guix-4168ddf689b3b7a176afd08c2c924f8e7ebb8c20.tar.gz
gnu: guile-gdbm-ffi: Install documentation.
* gnu/packages/guile.scm (guile-gdbm-ffi)[arguments]: Install README.md and some examples. Tidy up MKDIR-P calls.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 90630e8a36..c0fda71ead 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 ng0 <ng0@infotropique.org>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1074,13 +1075,16 @@ inspired by the SCSH regular expression system.")
(compile-file
(lambda (in-file out-file)
(system* guild "compile" "-o" out-file in-file))))
- ;; Make installation directories.
- (mkdir-p module-dir)
- (mkdir-p doc)
-
;; Switch directory for compiling and installing
(chdir source)
+ ;; Install the documentation.
+ (install-file "README.md" doc)
+ (copy-recursively "examples" (string-append doc "/examples"))
+
+ ;; Make installation directories.
+ (mkdir-p module-dir)
+
;; copy the source
(copy-file "gdbm.scm" gdbm.scm-dest)