summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-28 18:53:13 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-28 18:53:13 +0200
commit386b71d1b961a52201f64591076e51487a87bf0b (patch)
treedf2354ddeba7750d8fa39f5a9c4688ed2b6410af /gnu
parent6980511b7391e65a307689f90e4ef5c1979e4541 (diff)
downloadgnu-guix-386b71d1b961a52201f64591076e51487a87bf0b.tar
gnu-guix-386b71d1b961a52201f64591076e51487a87bf0b.tar.gz
gnu: commencement: 'guile-final' is now "hidden".
This way, we no longer have this annoying warning: $ guix build guile -n guix build: warning: ambiguous package specification `guile' guix build: warning: choosing guile-2.0.11 from gnu/packages/guile.scm:128:2 * gnu/packages/commencement.scm (guile-final): Use 'hidden-package'. * tests/packages.scm ("fold-packages, hidden package"): New test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c52b6e8389..54b524aec7 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -685,8 +685,10 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
,@(alist-delete "bash" %boot3-inputs)))
(define-public guile-final
+ ;; This package must be public because other modules refer to it. However,
+ ;; mark it as hidden so that 'fold-packages' ignores it.
(package-with-bootstrap-guile
- (package-with-explicit-inputs guile-2.0/fixed
+ (package-with-explicit-inputs (hidden-package guile-2.0/fixed)
%boot4-inputs
(current-source-location)
#:guile %bootstrap-guile)))