summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:50:51 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:01:11 +0000
commit0f0832d48f50f7da69c5e8fd69e7bb3bdd8a3254 (patch)
tree8ca2b9be9f77865e8fed94f8af4bda20f26c5402 /gnu
parenta9285c9030ea4adcc3f6c0e19e51b890cd787efa (diff)
downloadgnu-guix-0f0832d48f50f7da69c5e8fd69e7bb3bdd8a3254.tar
gnu-guix-0f0832d48f50f7da69c5e8fd69e7bb3bdd8a3254.tar.gz
gnu: Add ruby-launchy.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index eb1abdd3e3..56673b2051 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8473,3 +8473,25 @@ but it can function as a stand-alone templating engine.")
(home-page
"https://github.com/lostisland/faraday_middleware")
(license license:expat)))
+
+(define-public ruby-launchy
+ (package
+ (name "ruby-launchy")
+ (version "2.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "launchy" version))
+ (sha256
+ (base32
+ "190lfbiy1vwxhbgn4nl4dcbzxvm049jwc158r2x7kq3g5khjrxa2"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-addressable" ,ruby-addressable)))
+ (synopsis
+ "Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.")
+ (description
+ "Launchy is helper class for launching cross-platform applications in a fire and forget manner. There are application concepts (browser, email client, etc) that are common across all platforms, and they may be launched differently on each platform. Launchy is here to make a common approach to launching external application from within ruby programs.")
+ (home-page
+ "http://github.com/copiousfreetime/launchy")
+ (license #f)))