summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-25 19:27:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-03-25 21:41:26 +0200
commit063629aa3ef21e216357430ab1601fc58d0f4daf (patch)
tree731f9cd2c834393211848980a8f622ecaf55a26c /gnu
parent45f762ee968ff684107fb08f407bbea5e5852449 (diff)
downloadgnu-guix-063629aa3ef21e216357430ab1601fc58d0f4daf.tar
gnu-guix-063629aa3ef21e216357430ab1601fc58d0f4daf.tar.gz
gnu: Add jamvm-1-bootstrap.
* gnu/packages/java.scm (jamvm-1-bootstrap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 882a8b462e..a8ba91127f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -258,6 +258,37 @@ language.")
;; GPLv2 or later, with special linking exception.
(license license:gpl2+)))
+;; This is the last version of JamVM that works with a version of GNU
+;; classpath that does not require ECJ.
+(define jamvm-1-bootstrap
+ (package
+ (name "jamvm")
+ (version "1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/jamvm/jamvm/"
+ "JamVM%20" version "/jamvm-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "06lhi03l3b0h48pc7x58bk9my2nrcf1flpmglvys3wyad6yraf36"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-classpath-install-dir="
+ (assoc-ref %build-inputs "classpath")))))
+ (inputs
+ `(("classpath" ,classpath-bootstrap)
+ ("jikes" ,jikes)
+ ("zlib" ,zlib)))
+ (home-page "http://jamvm.sourceforge.net/")
+ (synopsis "Small Java Virtual Machine")
+ (description "JamVM is a Java Virtual Machine conforming to the JVM
+specification edition 2 (blue book). It is extremely small. However, unlike
+other small VMs it supports the full spec, including object finalisation and
+JNI.")
+ (license license:gpl2+)))
+
(define ant-bootstrap
(package
(name "ant-bootstrap")