summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:39:58 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit02613cf54a2aefeb066d05a4090d6f3ed50ff903 (patch)
treef4c1015b6b0bce9ca79be9336fac91fcc929ed06 /gnu
parentf3f250ad32cfd75e242ca6e5cf091bcab96c9c8f (diff)
downloadgnu-guix-02613cf54a2aefeb066d05a4090d6f3ed50ff903.tar
gnu-guix-02613cf54a2aefeb066d05a4090d6f3ed50ff903.tar.gz
gnu: kde-frameworks: Add kdbusaddons.
* gnu/packages/kde-frameworks.scm (kdbusaddons): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 390c3e589a..e9938095a3 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -387,6 +387,42 @@ manipulations such as macro replacement, accessing user information and
many more.")
(license (list license:lgpl2.0+ license:lgpl2.1+))))
+(define-public kdbusaddons
+ (package
+ (name "kdbusaddons")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "183nxqrhz4qk4qfp1w4an0scp2dvfqcaqbpg4cgbgk0z590q0pkk"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("dbus" ,dbus)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* _
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (zero? (system* "dbus-launch" "ctest" ".")))))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Convenience classes for DBus")
+ (description "KDBusAddons provides convenience classes on top of QtDBus,
+as well as an API to create KDED modules.")
+ ;; Some source files mention lgpl2.0+, but the included license is
+ ;; the lgpl2.1. Some source files are under non-copyleft licenses.
+ (license license:lgpl2.1+)))
+
(define-public kwindowsystem
(package
(name "kwindowsystem")