summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 22:01:51 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:36 -0500
commit01614c4feaaf1ff942b08e9054bd3acf9399cae8 (patch)
treed1638c9e3fb7785ca5d7e6b975a6c2b342f0be1c /gnu
parent900e3c0e0e87e2da7e5297e39bbc8119b7209937 (diff)
downloadgnu-guix-01614c4feaaf1ff942b08e9054bd3acf9399cae8.tar
gnu-guix-01614c4feaaf1ff942b08e9054bd3acf9399cae8.tar.gz
gnu: Add python-zope-testrunner.
* gnu/packages/python.scm (python-zope-testrunner, python2-zope-testrunner): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3dd50ff389..1c9f9a6577 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6112,3 +6112,39 @@ forms, HTTP servers, regular expressions, and more.")
(define-public python2-zope-testing
(package-with-python2 python-zope-testing))
+
+(define-public python-zope-testrunner
+ (package
+ (name "python-zope-testrunner")
+ (version "4.4.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/z"
+ "/zope.testrunner/zope.testrunner-"
+ version ".zip"))
+ (sha256
+ (base32
+ "1r7iqknhh55y45f64mz5hghgvzx34h1i11k350s0avx6q8gznja1"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-six" ,python-six)
+ ("python-zope-exceptions" ,python-zope-exceptions)
+ ("python-zope-testing" ,python-zope-testing)
+ ("unzip" ,unzip)))
+ (propagated-inputs
+ `(("python-zope-interface" ,python-zope-interface)))
+ (home-page "http://pypi.python.org/pypi/zope.testrunner")
+ (synopsis "Zope testrunner script")
+ (description "Zope.testrunner provides a script for running Python
+tests.")
+ (license zpl2.1)))
+
+(define-public python2-zope-testrunner
+ (let ((base (package-with-python2 python-zope-testrunner)))
+ (package
+ (inherit base)
+ (native-inputs
+ (append (package-native-inputs base)
+ `(("python2-subunit" ,python2-subunit)
+ ("python2-mimeparse" ,python2-mimeparse)))))))