summaryrefslogtreecommitdiff
path: root/gnu/system
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-06-15 09:52:42 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-06-15 14:16:37 +0200
commit4ce4fc501035a8ef461e10d5f3df6ea3a63c7572 (patch)
tree1cfa6216bff505a57129d703428fdfcf284f65a6 /gnu/system
parent0017e55f892828f7a4d29a50f06e5146270ab8cb (diff)
downloadgnu-guix-4ce4fc501035a8ef461e10d5f3df6ea3a63c7572.tar
gnu-guix-4ce4fc501035a8ef461e10d5f3df6ea3a63c7572.tar.gz
system: Add os-with-u-boot.
* gnu/system/install.scm (os-with-u-boot): New procedure. * gnu/packages/bootloaders.scm (make-u-boot-package): Export. * doc/guix.texi (Building the Installation Image for ARM Boards): New subsection.
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/install.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 35f4ba9c24..6a3ae1947b 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -54,7 +54,8 @@
novena-installation-os
pine64-plus-installation-os
rk3399-puma-installation-os
- wandboard-installation-os))
+ wandboard-installation-os
+ os-with-u-boot))
;;; Commentary:
;;;
@@ -386,6 +387,19 @@ You have been warned. Thanks for being so brave.\x1b[0m
nvi ;:wq!
%base-packages))))
+(define* (os-with-u-boot os board #:key (bootloader-target "/dev/mmcblk0")
+ (triplet "arm-linux-gnueabihf"))
+ "Given OS, amend it with the u-boot bootloader for BOARD,
+installed to BOOTLOADER-TARGET (a drive), compiled for TRIPLET.
+
+If you want a serial console, make sure to specify one in your
+operating-system's kernel-arguments (\"console=ttyS0\" or similar)."
+ (operating-system (inherit os)
+ (bootloader (bootloader-configuration
+ (bootloader (bootloader (inherit u-boot-bootloader)
+ (package (make-u-boot-package board triplet))))
+ (target bootloader-target)))))
+
(define* (embedded-installation-os bootloader bootloader-target tty
#:key (extra-modules '()))
"Return an installation os for embedded systems.