summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2018-01-15 09:27:57 +0100
committerChris Marusich <cmmarusich@gmail.com>2018-01-15 23:58:13 -0800
commitae307724de2957bbed6b763a1d039dba0876b5a7 (patch)
treef481e20088361ab78ccef4a55837736a30f46f06 /gnu/packages
parent403f2dccfcf992573ceeeae7c76c71b4884d3cd4 (diff)
downloadgnu-guix-ae307724de2957bbed6b763a1d039dba0876b5a7.tar
gnu-guix-ae307724de2957bbed6b763a1d039dba0876b5a7.tar.gz
gnu: java-classpathx-servletapi: Update to 3.0.1.
* gnu/packages/java.scm (java-classpathx-servletapi): Update to 3.0.1. [arguments]: Switch to a java8 compiler, remove comment about not working with java8. Signed-off-by: Chris Marusich <cmmarusich@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/java.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ec45561ad0..c04b45c536 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2018,25 +2018,20 @@ debugging, etc.")
(define-public java-classpathx-servletapi
(package
(name "java-classpathx-servletapi")
- (version "3.0")
+ (version "3.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/classpathx/servletapi/"
"servletapi-" version ".tar.gz"))
(sha256
(base32
- "0y9489pk4as9q6x300sk3ycc0psqfxcd4b0xvbmf3rhgli8q1kx3"))))
+ "07d8h051siga2f33fra72hk12sbq1bxa4jifjg0qj0vfazjjff0x"))))
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there is no test target
#:build-target "compile"
- ;; NOTE: This package does not build with Java 8 because of a type
- ;; mismatch in
- ;; "source/javax/servlet/jsp/el/ImplicitObjectELResolver.java". It
- ;; defines the return value of ScopeMap's "remove" method to be of type
- ;; "Object", whereas Map's "remove" method returns boolean.
#:make-flags
- (list "-Dbuild.compiler=javac1.7"
+ (list "-Dbuild.compiler=javac1.8"
(string-append "-Ddist=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases