summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-20 21:35:49 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commitf5594729395becfcac2a48abc4448c40fc519a4e (patch)
tree78ffe04927511e21f3c29ec74d88e51e47e81690 /gnu/packages
parentf82cef25cae00bda3e019a8e056b76f001f0f425 (diff)
downloadgnu-guix-f5594729395becfcac2a48abc4448c40fc519a4e.tar
gnu-guix-f5594729395becfcac2a48abc4448c40fc519a4e.tar.gz
gnu: Add perl-env-path.
* gnu/packages/perl.scm (perl-env-path): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index edb0ba8198..d2abca2eac 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2027,6 +2027,29 @@ SHA-1 message digest algorithm for use by Perl programs.")
modules separately and deal with them after the module is done installing.")
(license (package-license perl))))
+(define-public perl-env-path
+ (package
+ (name "perl-env-path")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DS/DSB/Env-Path-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1qhmj15a66h90pjl2dgnxsb9jj3b1r5mpvnr87cafcl8g69z0jr4"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Env-Path")
+ (synopsis "Advanced operations on path variables")
+ (description "@code{Env::Path} presents an object-oriented interface to
+path variables, defined as that subclass of environment variables which name
+an ordered list of filesystem elements separated by a platform-standard
+separator.")
+ (license (package-license perl))))
+
(define-public perl-error
(package
(name "perl-error")