summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-22 18:14:33 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 21:29:08 +0200
commitf25e3b39d9fb27d2515c1f074847a5c99d025ce4 (patch)
treee6370ce9e62dc164aae80da5d28974f1e920fcb0 /gnu/packages
parente25ddef5bd15d532c52a4f868c22c6cea601b16c (diff)
downloadgnu-guix-f25e3b39d9fb27d2515c1f074847a5c99d025ce4.tar
gnu-guix-f25e3b39d9fb27d2515c1f074847a5c99d025ce4.tar.gz
gnu: Add go-gitlab-com-ambrevar-golua-unicode.
* gnu/packages/golang.scm (go-gitlab-com-ambrevar-golua-unicode): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9bcf1c7bdd..c941b5439a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2106,3 +2106,41 @@ generate ANSI colored strings.")
(description "This package provides @code{lua}, a Go module that can
run a Lua virtual machine.")
(license license:expat))))
+
+(define-public go-gitlab-com-ambrevar-golua-unicode
+ (let ((commit "97ce517e7a1fe2407a90c317a9c74b173d396144")
+ (revision "0"))
+ (package
+ (name "go-gitlab-com-ambrevar-golua-unicode")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://gitlab.com/ambrevar/golua")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1izcp7p8nagjwqd13shb0020w7xhppib1a3glw2d1468bflhksnm"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("lua" ,lua)
+ ("go-github-com-aarzilli-golua" ,go-github-com-aarzilli-golua)))
+ (arguments
+ `(#:unpack-path "gitlab.com/ambrevar/golua"
+ #:import-path "gitlab.com/ambrevar/golua/unicode"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key import-path #:allow-other-keys)
+ (setenv "USER" "homeless-dude")
+ (invoke "go" "test" import-path))))))
+ (home-page "https://gitlab.com/ambrevar/golua")
+ (synopsis "Add Unicode support to Golua")
+ (description "This extension to Arzilli's Golua adds Unicode support to
+all functions from the Lua string library. Lua patterns are replaced by Go
+regexps. This breaks compatibility with Lua, but Unicode support breaks it
+anyways and Go regexps are more powerful.")
+ (license license:expat))))