summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-07-22 20:35:12 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 20:35:12 +0200
commita86866f4b5e6ddaecc5484ac35f0f9b9752cf630 (patch)
tree711cd152f442162eb1d78dd1d0287483f6941c99 /gnu/packages
parentcb19df37f3d4e482d27d3fc3711d66d84c770a67 (diff)
downloadgnu-guix-a86866f4b5e6ddaecc5484ac35f0f9b9752cf630.tar
gnu-guix-a86866f4b5e6ddaecc5484ac35f0f9b9752cf630.tar.gz
gnu: Add emacs-ztree.
* gnu/packages/emacs.scm (emacs-ztree): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3233d66f62..fca34f9de1 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11533,3 +11533,27 @@ files. It focuses on highlighting the document to improve readability.")
source code.")
(license (list license:expat
license:asl2.0)))))
+
+(define-public emacs-ztree
+ (let ((commit "c54425a094353ec40a8179f9eab3596f76c6cf94"))
+ (package
+ (name "emacs-ztree")
+ (version (git-version "1.0.5" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fourier/ztree")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0j8fpxds8m1zi04nrs8vv21091abvh4n8ab76f1sgdxnp4l5cfb0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/fourier/ztree")
+ (synopsis "Directory tree comparison mode for Emacs")
+ (description "Ztree is a project dedicated to implementation of several
+text-tree applications inside GNU Emacs. It consists of 2 subprojects:
+@command{ztree-diff} and @command{ztree-dir} (the basis of
+@command{ztree-diff}).")
+ (license license:gpl3))))