summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-01-21 14:15:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-24 13:19:07 +0100
commita204c14cb587e536870c5294d0536755a2bcb68e (patch)
tree3cff329ab1f7819be727613226d905f43366ce42 /gnu/packages
parent9c058ef2f2b8a8049933160a9346ec4b96fe9ead (diff)
downloadgnu-guix-a204c14cb587e536870c5294d0536755a2bcb68e.tar
gnu-guix-a204c14cb587e536870c5294d0536755a2bcb68e.tar.gz
gnu: Add emacs-oauth2.
* gnu/packages/emacs.scm (emacs-oauth2): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8c279b63f7..ce4c764708 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6521,6 +6521,31 @@ writers, to write applications that use WebSockets, and is not useful by
itself.")
(license license:gpl3+)))
+(define-public emacs-oauth2
+ (package
+ (name "emacs-oauth2")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/oauth2-"
+ version ".el"))
+ (sha256
+ (base32
+ "0ydkc9jazsnbbvfhd47mql52y7k06n3z7r0naqxkwb99j9blqsmp"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/oauth2.html")
+ (synopsis "OAuth 2.0 authorization protocol implementation")
+ (description
+ "This package provides an Elisp implementation of the OAuth 2.0 draft.
+The main entry point is @code{oauth2-auth-and-store} which will return a token
+structure. This token structure can be then used with
+@code{oauth2-url-retrieve-synchronously} or @code{oauth2-url-retrieve} to
+retrieve any data that need OAuth authentication to be accessed. If the token
+needs to be refreshed, the code handles it automatically and stores the new
+value of the access token.")
+ (license license:gpl3+)))
+
(define-public emacs-bash-completion
(package
(name "emacs-bash-completion")