summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-25 05:15:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-25 05:17:42 +0200
commit7753b5436687bdf913439d1ab74b13b0b39b630b (patch)
tree5afc5e535f58195ac0765b402949c78805cc352c /gnu/packages
parent6ce07cf99dc417067f0e76efc7fc53f8292377b7 (diff)
downloadgnu-guix-7753b5436687bdf913439d1ab74b13b0b39b630b.tar
gnu-guix-7753b5436687bdf913439d1ab74b13b0b39b630b.tar.gz
gnu: Add r-multcomp.
* gnu/packages/cran.scm (r-multcomp): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0a4ed76aad..361140c822 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6322,3 +6322,31 @@ cross-sectional, time series, clustered, panel, and longitudinal data.")
"This package contains supporting data sets that are used in other
packages maintained by Torsten Hothorn.")
(license license:gpl3)))
+
+(define-public r-multcomp
+ (package
+ (name "r-multcomp")
+ (version "1.4-8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "multcomp" version))
+ (sha256
+ (base32
+ "0fm78g4zjc6ank316qfw977864shmy890znn4fahwc8jjdhpc252"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-codetools" ,r-codetools)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-sandwich" ,r-sandwich)
+ ("r-survival" ,r-survival)
+ ("r-th-data" ,r-th-data)))
+ (home-page "https://cran.r-project.org/web/packages/multcomp/")
+ (synopsis "Simultaneous inference in general parametric models")
+ (description
+ "Simultaneous tests and confidence intervals for general linear
+hypotheses in parametric models, including linear, generalized linear, linear
+mixed effects, and survival models. The package includes demos reproducing
+analyzes presented in the book \"Multiple Comparisons Using R\" (Bretz,
+Hothorn, Westfall, 2010, CRC Press).")
+ (license license:gpl2)))