summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-12 16:17:29 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commit608dd932674def26c02bb255ebabcb62442f1093 (patch)
tree60d4c4b8cda5f4edbc52f85b05f806d79366d4c6 /gnu/packages
parent024130d2581b8dcdc0954b3c375afda29815806e (diff)
downloadgnu-guix-608dd932674def26c02bb255ebabcb62442f1093.tar
gnu-guix-608dd932674def26c02bb255ebabcb62442f1093.tar.gz
gnu: Add raxml.
* gnu/packages/bioinformatics.scm (raxml): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 81431562f2..df6c487198 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3380,6 +3380,46 @@ format. It runs quickly, in an unsupervised fashion, handles gaps, handles
partial genes, and identifies translation initiation sites.")
(license license:gpl3+)))
+(define-public raxml
+ (package
+ (name "raxml")
+ (version "8.2.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://github.com/stamatak/standard-RAxML/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pv8p2fy67y21a9y4cm7xpvxqjwz2v4201flfjshdq1p8j52rqf7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ ;; Use 'standard' Makefile rather than SSE or AVX ones.
+ #:make-flags (list "-f" "Makefile.HYBRID.gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (executable "raxmlHPC-HYBRID"))
+ (install-file executable bin)
+ (symlink (string-append bin "/" executable) "raxml"))
+ #t)))))
+ (inputs
+ `(("openmpi" ,openmpi)))
+ (home-page "http://sco.h-its.org/exelixis/web/software/raxml/index.html")
+ (synopsis "Randomized Axelerated Maximum Likelihood phylogenetic trees")
+ (description
+ "RAxML is a tool for phylogenetic analysis and post-analysis of large
+phylogenies.")
+ (license license:gpl2+)))
+
(define-public rsem
(package
(name "rsem")