summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-07-22 19:55:06 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 19:55:06 +0200
commit3ad4443f68fe4afc0ff3415e7143872c6ad2cdb3 (patch)
tree2b35cf0d1e1d15cd427670c329779699bba3a410 /gnu/packages
parentdb4c03e24906b0d1b2ea817fbabace0b8c48bd92 (diff)
downloadgnu-guix-3ad4443f68fe4afc0ff3415e7143872c6ad2cdb3.tar
gnu-guix-3ad4443f68fe4afc0ff3415e7143872c6ad2cdb3.tar.gz
gnu: emacs-wgrep: Update to 20180711.
* gnu/packages/emacs.scm (emacs-wgrep): Update to 20180711.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ff8cc3b069..083d9eab5b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4576,25 +4576,28 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(license license:gpl3+)))
(define-public emacs-wgrep
- (package
- (name "emacs-wgrep")
- (version "2.1.10")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/mhayashi1120/Emacs-wgrep/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1r2bpypar70xg6dsx12x1k74f39ww930rday7rgqpyknzsx1k4l1"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
- (synopsis "Edit a grep buffer and apply those changes to the files")
- (description
- "Emacs wgrep allows you to edit a grep buffer and apply those changes to
-the file buffer.")
- (license license:gpl3+)))
+ (let ((commit "414be70bd313e482cd9f0b70fd2daad4ee23497c"))
+ ;; Late commit fixes compatibility issue with Emacs 26+.
+ (package
+ (name "emacs-wgrep")
+ (version (git-version "2.1.10" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mhayashi1120/Emacs-wgrep")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sdhd587q3pg92lhiayph87azhalmf1gzrnsprkmqvnphv7mvks9"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
+ (synopsis "Edit a grep buffer and apply those changes to the files")
+ (description
+ "Emacs wgrep allows you to edit a grep buffer and apply those changes
+to the file buffer. Several backends are supported beside the classic grep:
+ack, ag, helm and pt.")
+ (license license:gpl3+))))
(define-public emacs-helm
(package