summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-06-17 20:23:42 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-06-17 20:23:42 +0800
commit33f61dc1b5e14f8a2e3dfb3fb48102bda0fd6b13 (patch)
tree8b3cc9a35ae0da57c74af5d2a6bcf02a00f24e5d /gnu/packages
parentc5829179caeca969d02fb83d86a29b1012761e92 (diff)
downloadgnu-guix-33f61dc1b5e14f8a2e3dfb3fb48102bda0fd6b13.tar
gnu-guix-33f61dc1b5e14f8a2e3dfb3fb48102bda0fd6b13.tar.gz
gnu: Remove Mr. Rescue.
It's not compatible with love-11.1. * gnu/packages/game.scm (mrrescue): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e5d5765ff3..06ac1b80bb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3252,53 +3252,6 @@ application that locks the keyboard and mouse and instead displays bright
colors, pictures, and sounds.")
(license license:gpl3+)))
-(define-public mrrescue
- (package
- (name "mrrescue")
- (version "1.02e")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/SimonLarsen/mrrescue/releases/"
- "download/" version "/" name version ".love"))
- (file-name (string-append name "-" version ".love"))
- (sha256
- (base32
- "0jwzbwkgp1l5ia6c7s760gmdirbsncp6nfqp7vqdqsfb63la9gl2"))))
- (build-system trivial-build-system)
- (arguments
- '(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let* ((out (assoc-ref %outputs "out"))
- (bindir (string-append out "/bin"))
- (prog (string-append bindir "/mrrescue"))
- (source (assoc-ref %build-inputs "source"))
- (bash (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash"))
- (love (string-append (assoc-ref %build-inputs "love")
- "/bin/love")))
- (mkdir-p bindir)
- (with-output-to-file prog
- (lambda ()
- (format #t "#!~a~%" bash)
- (format #t "exec -a mrrescue \"~a\" \"~a\"~%" love source)))
- (chmod prog #o755)
- #t))))
- (inputs
- `(("bash" ,bash)
- ("love" ,love)))
- (home-page "http://tangramgames.dk/games/mrrescue")
- (synopsis "Arcade-style fire fighting game")
- (description
- "Mr. Rescue is an arcade styled 2d action game centered around evacuating
-civilians from burning buildings. The game features fast paced fire
-extinguishing action, intense boss battles, a catchy soundtrack and lots of
-throwing people around in pseudo-randomly generated buildings.")
- (license (list license:zlib ; for source code
- license:cc-by-sa3.0)))) ; for graphics and music assets
-
(define-public hyperrogue
(package
(name "hyperrogue")