summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-31 01:27:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-31 02:31:18 +0100
commit1d9a9d27ae4d7981a0df749708b683859ee5c58e (patch)
tree2d1fe0fdbd9496289bf9561fbbe1369d26eee260 /gnu/packages
parent4cae7e67f3164b0626a2a25215f5d94141a860da (diff)
downloadgnu-guix-1d9a9d27ae4d7981a0df749708b683859ee5c58e.tar
gnu-guix-1d9a9d27ae4d7981a0df749708b683859ee5c58e.tar.gz
gnu: meandmyshadow: Update to 0.5.
* gnu/packages/games.scm (meandmyshadow): Update to 0.5. [source]: Add unreleased bugfix patch. [arguments]: Remove obsolete ‘set-sdl'paths’ phase. [inputs]: Switch to SDL 2. Add lua. Remove libx11, mesa, and glu. * gnu/packages/patches/meandmyshadow-define-paths-earlier.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm38
-rw-r--r--gnu/packages/patches/meandmyshadow-define-paths-earlier.patch50
2 files changed, 62 insertions, 26 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e28dd9fa83..250f6151ef 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -572,7 +572,7 @@ automata. The following features are available:
(define-public meandmyshadow
(package
(name "meandmyshadow")
- (version "0.4.1")
+ (version "0.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/meandmyshadow/"
@@ -580,37 +580,23 @@ automata. The following features are available:
"-src.tar.gz"))
(sha256
(base32
- "0wl5dc75qy001s6043cx0vr2l5y2qfv1cldqnwill9sfygqj9p95"))))
+ "1b6qf83vdfv8jwn2jq9ywmda2qn2f5914i7mwfy04m17wx593m3m"))
+ (patches (search-patches
+ ;; This will not be needed in the next release.
+ "meandmyshadow-define-paths-earlier.patch"))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f ; there are no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'set-sdl'paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "cmake/Modules/FindSDL_gfx.cmake"
- (("/usr/local/include/SDL")
- (string-append (assoc-ref inputs "sdl")
- "/include/SDL")))
- ;; Because SDL provides lib/libX11.so.6 we need to explicitly
- ;; link with libX11, even though we're using the GL backend.
- (substitute* "CMakeLists.txt"
- (("\\$\\{X11_LIBRARIES\\}") "-lX11"))
- #t)))))
+ `(#:tests? #f)) ; there are no tests
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("sdl" ,(sdl-union (list sdl
- sdl-image
- sdl-gfx
- sdl-mixer
- sdl-ttf)))
- ("libx11" ,libx11) ; needed by sdl's libX11
+ `(("curl" ,curl)
("libarchive" ,libarchive)
- ("openssl" ,openssl)
- ("mesa" ,mesa)
- ("glu" ,glu)
- ("curl" ,curl)))
+ ("lua" ,lua)
+ ("sdl" ,(sdl-union (list sdl2
+ sdl2-image
+ sdl2-mixer
+ sdl2-ttf)))))
(home-page "http://meandmyshadow.sourceforge.net/")
(synopsis "Puzzle/platform game")
(description "Me and My Shadow is a puzzle/platform game in which you try
diff --git a/gnu/packages/patches/meandmyshadow-define-paths-earlier.patch b/gnu/packages/patches/meandmyshadow-define-paths-earlier.patch
new file mode 100644
index 0000000000..505cbd23fe
--- /dev/null
+++ b/gnu/packages/patches/meandmyshadow-define-paths-earlier.patch
@@ -0,0 +1,50 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Wed, 31 Oct 2018 02:24:26 +0100
+Subject: [PATCH] gnu: meandmyshadow: Define paths earlier.
+
+The following patch was taken verbatim from the upstream repository[0]
+and will be included in the next release.
+
+[0]: https://github.com/acmepjz/meandmyshadow/pull/29
+---
+From 4847e6b5755258a1e0534f2d4b91dce2ce3b459e Mon Sep 17 00:00:00 2001
+From: Dmitry Marakasov <amdmi3@amdmi3.ru>
+Date: Wed, 24 Oct 2018 23:31:19 +0300
+Subject: [PATCH] Define paths earlier in CMakeLists.txt
+
+At the very least, paths should be defined before Configure_File(), otherwise empty DATAROOTDIR is substituted in config.h
+---
+ CMakeLists.txt | 13 +++++++------
+ 1 file changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e79639a..6321d9d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,6 +2,13 @@ Project (meandmyshadow)
+ CMake_Minimum_Required (VERSION 3.1)
+ Set (CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+
++#Path options
++Set (BINDIR "bin" CACHE STRING "Where to install binaries")
++Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
++Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
++Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
++
++#Options
+ Option (DEBUG_MODE "Compile the game with debug mode enabled" OFF)
+ Option (DISABLED_DEBUG_STUFF "Enable this you'll see a lot of annoying script debug messages which will lag the game." OFF)
+
+@@ -164,12 +171,6 @@ Target_Link_Libraries (
+ ${LUA_LIBRARIES}
+ )
+
+-#Path options
+-Set (BINDIR "bin" CACHE STRING "Where to install binaries")
+-Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
+-Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
+-Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
+-
+ #Install locations
+ Install (DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${DATAROOTDIR}/meandmyshadow/)
+ Install (FILES AUTHORS DESTINATION ${DATAROOTDIR}/meandmyshadow/)