summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:50:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:36 +0100
commit6f8deed6e3b945dd2c9622a24ff3b1ee3226a920 (patch)
treee226ebab32fb9575c7794665ba0e51d6baf31982 /gnu/packages/xml.scm
parente85de10877f21f82500ed79c5045de5c2e52a206 (diff)
downloadgnu-guix-6f8deed6e3b945dd2c9622a24ff3b1ee3226a920.tar
gnu-guix-6f8deed6e3b945dd2c9622a24ff3b1ee3226a920.tar.gz
gnu: Add ghc-hxt-regex-xmlschema.
* gnu/packages/xml.scm (ghc-hxt-regex-xmlschema): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index c538021cb0..480e65073b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2058,3 +2058,30 @@ are supported. Decoding is done with lazy functions, errors may be detected or
ignored.")
(license license:expat)))
+(define-public ghc-hxt-regex-xmlschema
+ (package
+ (name "ghc-hxt-regex-xmlschema")
+ (version "9.2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hxt-regex-xmlschema/hxt-regex-xmlschema-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1c4jr0439f5yc05h7iz53fa47g6l2wrvqp6gvwf01mlqajk3nx7l"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hxt-charproperties" ,ghc-hxt-charproperties)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-text" ,ghc-text)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://www.haskell.org/haskellwiki/Regular_expressions_for_XML_Schema")
+ (synopsis "Regular expression library for W3C XML Schema regular expressions")
+ (description
+ "This library supports full W3C XML Schema regular expressions inclusive
+all Unicode character sets and blocks. It is implemented by the technique of
+derivations of regular expressions.")
+ (license license:expat)))
+