summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-10 12:46:24 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-10 12:57:32 +0100
commit2b8c5f547ac98b210d855e7ccb67e23cd344e3eb (patch)
treeda170367b6cb0a3840f01b274d5e667a62a37be9 /gnu/packages/xml.scm
parent68a3d0e8cd9b0998abbe1c7e15d0de3107dda0f5 (diff)
downloadgnu-guix-2b8c5f547ac98b210d855e7ccb67e23cd344e3eb.tar
gnu-guix-2b8c5f547ac98b210d855e7ccb67e23cd344e3eb.tar.gz
gnu: Add intltool.
* gnu/packages/xml.scm (intltool): New variable. * gnu/packages/xml.scm (perl-xml-parser): Fix download location.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm40
1 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 7b3d222cb0..2c4cda54a3 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -126,7 +126,7 @@ based on libxml for XML parsing, tree manipulation and XPath support.")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/M/MS/MSERGEANT/XML-Parser-"
+ "mirror://cpan/authors/id/T/TO/TODDR/XML-Parser-"
version ".tar.gz"))
(sha256
(base32
@@ -149,3 +149,41 @@ then passed on to the Expat object on each parse call. They can also be given
as extra arguments to the parse methods, in which case they override options
given at XML::Parser creation time.")
(home-page "http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm")))
+
+(define-public intltool
+ (package
+ (name "intltool")
+ (version "0.50.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/intltool/trunk/"
+ version "/+download/intltool-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "01j4yd7i84n9nk4ccs6yifg84pp68nr9by57jdbhj7dpdxf5rwk7"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("perl" ,perl)
+ ("perl-xml-parser" ,perl-xml-parser)))
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure))
+ (perl-xml-parser (assoc-ref inputs "perl-xml-parser")))
+ ;; FIXME: This should be done more centrally.
+ (setenv "PERL5LIB" (string-append perl-xml-parser "/lib/perl5/site_perl"))
+ (apply configure args)))
+ %standard-phases)))
+ (home-page "https://launchpad.net/intltool/+download")
+ (synopsis "Utility scripts for internationalising xml")
+ (description
+ "intltool automatically extracts translatable strings from oaf, glade,
+bonobo ui, nautilus theme and other XML files into the po files.
+It automatically merges translations from po files back into .oaf files
+(encoding to be 7-bit clean). The merging mechanism can also be extended to
+support other types of XML files.")
+ (license license:gpl2+)))
+