summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-08 23:01:39 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-08 23:03:07 +0100
commit11e3f107884d5f8139ff82c9de5a7ac7ac43727f (patch)
tree228630957598c1c60d814ec520af2cc241859e72 /gnu/packages/xml.scm
parent322cbda7c5e89e9393310555e3158b83b24c713c (diff)
downloadgnu-guix-11e3f107884d5f8139ff82c9de5a7ac7ac43727f.tar
gnu-guix-11e3f107884d5f8139ff82c9de5a7ac7ac43727f.tar.gz
gnu: libxslt: Add zlib and libxml2 python module to inputs.
* gnu/packages/xml.scm (libxslt): Add input zlib and add libxml2 to PYTHONPATH.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ab9fd4bffc..7b3d222cb0 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -101,7 +101,19 @@ things the parser might find in the XML document (like start tags).")
(synopsis "libxslt, a C library for applying XSLT stylesheets to XML documents")
(inputs `(("libgcrypt" ,libgcrypt)
("libxml2" ,libxml2)
- ("python" ,python)))
+ ("python" ,python)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure))
+ (libxml2 (assoc-ref inputs "libxml2")))
+ ;; FIXME: This should be done more centrally.
+ (setenv "PYTHONPATH" (string-append libxml2 "/lib/python2.7/site-packages"))
+ (apply configure args)))
+ %standard-phases)))
(description
"Libxslt is an XSLT C library developed for the GNOME project. It is
based on libxml for XML parsing, tree manipulation and XPath support.")