summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-27 09:31:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-29 16:06:14 +0200
commitb8d3a000efca885180277358caa3c4fe604168a5 (patch)
treeaf8def49bcdccca464e97d9a6508a9e20f438ba6 /gnu/packages/xfce.scm
parentc860d6ef235b47ec8181fbf390e0b42fbc95dcfe (diff)
downloadgnu-guix-b8d3a000efca885180277358caa3c4fe604168a5.tar
gnu-guix-b8d3a000efca885180277358caa3c4fe604168a5.tar.gz
gnu: libxfce4ui: Do not propagate gtk+-2.
Propagation of both gtk+ and gtk+-2 causes a conflict to be detected, preventing the installation of xfce. * gnu/packages/xfce.scm (libxfce4ui)[propagated-inputs]: Move "gtk+-2"... [inputs]: ...to here. (garcon)[inputs]: Add "gtk+-2". (xfce4-appfinder)[inputs]: Add "gtk+-2". (xfce4-power-manager)[inputs]: Add "gtk+-2". (ristretto)[inputs]: Add "gtk+-2".
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index d54b7f6401..101909b1e4 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -159,13 +159,15 @@ storage system.")
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
(propagated-inputs
- `(("gtk+-2" ,gtk+-2) ; required by libxfce4ui-1.pc
- ("gtk+-3" ,gtk+) ; required by libxfce4ui-2.pc
+ `(("gtk+-3" ,gtk+) ; required by libxfce4ui-2.pc
;; libxfce4kbd-private-2.pc refers to all these.
("libxfce4util" ,libxfce4util)
("xfconf" ,xfconf)))
(inputs `(("libsm" ,libsm)
("libice" ,libice)
+ ;; FIXME: required by libxfce4ui-1.pc, so should be propagated,
+ ;; but will lead to a conflict with gtk+.
+ ("gtk+-2" ,gtk+-2)
("startup-notification" ,startup-notification)))
(home-page "http://www.xfce.org/")
(synopsis "Widgets library for Xfce")
@@ -221,6 +223,8 @@ development.")
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)
("glib:bin" ,glib "bin")))
+ (inputs
+ `(("gtk+" ,gtk+-2)))
(propagated-inputs
`(("libxfce4ui" ,libxfce4ui))) ; required by garcon-gtk2-1.pc
(home-page "http://www.xfce.org/")
@@ -452,6 +456,7 @@ per window.")
("intltool" ,intltool)))
(inputs
`(("garcon" ,garcon)
+ ("gtk+" ,gtk+-2)
("libxfce4ui" ,libxfce4ui)))
(home-page "http://www.xfce.org/")
(synopsis "Xfce application finder")
@@ -759,6 +764,7 @@ system resources, while still being visually appealing and user friendly.")
("intltool" ,intltool)))
(inputs
`(("lbxrandr" ,libxrandr)
+ ("gtk+" ,gtk+-2)
("upower" ,upower)
("libnotify" ,libnotify)
("libxfce4ui" ,libxfce4ui)))
@@ -792,6 +798,7 @@ inhibit interface which allows applications to prevent automatic sleep.")
("pkg-config" ,pkg-config)))
(inputs
`(("desktop-file-utils" ,desktop-file-utils)
+ ("gtk+" ,gtk+-2)
("libexif" ,libexif)
("libxfce4ui" ,libxfce4ui)
("librsvg" ,librsvg)