summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-12-19 10:45:15 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-19 18:11:56 +0100
commit68f1869cfca63ee361b2b036eb424f20a9da0d91 (patch)
tree5b174fcc32e2d93aff29d0fd9c74420da4ba4bf6 /gnu/packages/xfce.scm
parent9a56cf2b5b4970843c215091ea9823a67e077310 (diff)
downloadgnu-guix-68f1869cfca63ee361b2b036eb424f20a9da0d91.tar
gnu-guix-68f1869cfca63ee361b2b036eb424f20a9da0d91.tar.gz
gnu: xfce4-session: Disable (duplicate) Gtk+ icon cache generation.
* gnu/packages/xfce.scm (xfce4-session)[arguments]: Add make-flags to disable Gtk+ icon cache generation.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 7668a1d380..bbe6ab4545 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -492,7 +492,10 @@ your system in categories, so you can quickly find and launch them.")
(build-system gnu-build-system)
(arguments
'(#:configure-flags
- (list (string-append "--with-xsession-prefix=" %output))))
+ (list (string-append "--with-xsession-prefix=" %output))
+ ;; Disable icon cache update.
+ #:make-flags
+ '("gtk_update_icon_cache=true")))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))