summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-01 07:48:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:55 +0200
commita145d7e9af6452f3514ab130db534e4592a9c2b9 (patch)
tree8d6e3655de9e248af445fbec70f99b319428b160 /gnu/packages/web.scm
parentb8150fa091ce42c7837c6bfb9be8b96656470df2 (diff)
downloadgnu-guix-a145d7e9af6452f3514ab130db534e4592a9c2b9.tar
gnu-guix-a145d7e9af6452f3514ab130db534e4592a9c2b9.tar.gz
gnu: python-clf: Use INVOKE.
* gnu/packages/web.scm (python-clf)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0be62ac12c..36757ba8f9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5305,14 +5305,15 @@ internetarchive python module for programatic access to archive.org.")
(modify-phases %standard-phases
(add-after 'unpack 'get-tests
(lambda _
- (copy-file (assoc-ref %build-inputs "test-clf") "test_clf.py")))
+ (copy-file (assoc-ref %build-inputs "test-clf") "test_clf.py")
+ #t))
(replace 'check
(lambda _
- (zero? (system* "nosetests"
- ;; These tests require internet connection
- "--exclude=test_browse"
- "--exclude=test_command"
- "--exclude=test_search")))))))
+ (invoke "nosetests"
+ ;; These tests require an Internet connection.
+ "--exclude=test_browse"
+ "--exclude=test_command"
+ "--exclude=test_search"))))))
(home-page "https://github.com/ncrocfer/clf")
(synopsis "Search code snippets on @url{https://commandlinefu.com}")
(description "@code{clf} is a command line tool for searching code