summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-03 23:35:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-03 23:35:29 +0300
commit6c277c8999014f06c296106101efd0923d7476fe (patch)
treefaf8c7645bff6570607e6a1745a29a315bd16617 /gnu/packages/web.scm
parent8d9ac9262226f3a356552a55e3f833c10ed12d69 (diff)
downloadgnu-guix-6c277c8999014f06c296106101efd0923d7476fe.tar
gnu-guix-6c277c8999014f06c296106101efd0923d7476fe.tar.gz
gnu: libpsl: Update to 0.13.0.
* gnu/packages/web.scm (libpsl): Update to 0.13.0. [arguments]: Remove bootstrap phase. [inputs]: Add python-2. [native-inputs]: Remove autoconf, automake, gettext, which, libtool, pkg-config.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm25
1 files changed, 8 insertions, 17 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6dabc06be5..1f13474e95 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -355,29 +356,19 @@ for efficient socket-like bidirectional reliable communication channels.")
(define-public libpsl
(package
(name "libpsl")
- (version "0.7.1")
+ (version "0.13.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/rockdaboot/libpsl/"
- "archive/libpsl-" version ".tar.gz"))
+ "releases/download/libpsl-" version
+ "/libpsl-" version ".tar.gz"))
(sha256
(base32
- "1k0klj668c9v0r4993vfs3kq773mzdz61vsigqw6v1mjcwnf1si3"))))
+ "0afn2c4s2m65xifa5sfdll0s2gyqbh2q9k9nq4nsmx1b6c2i3i7x"))))
(build-system gnu-build-system)
- (inputs `(("icu4c" ,icu4c)))
- ;; The release tarball lacks the generated files.
- (native-inputs `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gnu-gettext)
- ("which" ,which)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
- (arguments
- `(#:phases (alist-cons-after
- 'unpack 'bootstrap
- (lambda _
- (zero? (system* "sh" "autogen.sh")))
- %standard-phases)))
+ (inputs
+ `(("icu4c" ,icu4c)
+ ("python-2" ,python-2)))
(home-page "https://github.com/rockdaboot/libpsl")
(synopsis "C library for the Publix Suffix List")
(description