summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-30 08:32:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-10-30 21:48:10 +0100
commit65279cc8f38373ef455e7c94019388d78d544ce6 (patch)
tree611606ba0d75eb23231241375b7cb8a4474b7d4d /gnu/packages/web.scm
parenta056e2251e8d3fe24d3c989b5a0093e203bda1e0 (diff)
downloadgnu-guix-65279cc8f38373ef455e7c94019388d78d544ce6.tar
gnu-guix-65279cc8f38373ef455e7c94019388d78d544ce6.tar.gz
gnu: Add r-shinyfiles.
* gnu/packages/web.scm (r-shinyfiles): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0c3a13a853..849220c099 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5645,6 +5645,35 @@ application framework for R, making it easy to create attractive dashboards.")
;; later.
(license l:gpl2+)))
+(define-public r-shinyfiles
+ (package
+ (name "r-shinyfiles")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "shinyFiles" version))
+ (sha256
+ (base32
+ "1cbg09l7w2zbgxb4qjm9p873p0lzrihlzsk5xxi3cpxdckn6zsrm"))))
+ (properties `((upstream-name . "shinyFiles")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fs" ,r-fs)
+ ("r-htmltools" ,r-htmltools)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-shiny" ,r-shiny)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/thomasp85/shinyFiles")
+ (synopsis "Server-side file system viewer for Shiny")
+ (description
+ "This package provides functionality for client-side navigation of the
+server side file system in shiny apps. In case the app is running locally
+this gives the user direct access to the file system without the need to
+\"download\" files to a temporary location. Both file and folder selection as
+well as file saving is available.")
+ (license l:gpl2+)))
+
(define-public r-crosstalk
(package
(name "r-crosstalk")