summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorRaphaël Mélotte <raphael.melotte@posteo.net>2018-08-20 16:20:05 +0200
committerLudovic Courtès <ludo@gnu.org>2018-08-21 23:27:09 +0200
commitf9984535593de3f76d0df669f15e67061e18cd24 (patch)
tree9b2b0d73b3e348f2bfdd1e56fe01a1f5c800ddc4 /gnu/packages/web-browsers.scm
parentc305ac30c397a482a1758fa8c02bc5716c9d3a12 (diff)
downloadgnu-guix-f9984535593de3f76d0df669f15e67061e18cd24.tar
gnu-guix-f9984535593de3f76d0df669f15e67061e18cd24.tar.gz
gnu: luakit: Fix crash on startup.
* gnu/packages/web-browsers.scm (luakit): add XDG_CONFIG_DIRS to the wrapping phase. This fixes a crash when no configuration file is present in the user's home directory. It allows luakit to use it's own default configuration files. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 397f4a3133..45252c933d 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -187,7 +187,9 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
(wrap-program (string-append luakit "/bin/luakit")
`("LUA_CPATH" prefix
(,(string-append lua5.1-filesystem
- "/lib/lua/5.1/?.so;;"))))
+ "/lib/lua/5.1/?.so;;")))
+ `("XDG_CONFIG_DIRS" prefix
+ (,(string-append luakit "/etc/xdg/"))))
#t))))))
(synopsis "Fast, lightweight, and simple browser based on WebKit")
(description "Luakit is a fast, lightweight, and simple to use