summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-08 13:39:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-18 01:16:03 +0100
commit0df77274d1e1e143a54adfef96150b182977fa61 (patch)
treeeb8d0ef344501886ef8180f598d613dd03500bfd /gnu/packages/vulkan.scm
parent6713e9cb7efbf68bdca2057d85e96b0f1e86c348 (diff)
downloadgnu-guix-0df77274d1e1e143a54adfef96150b182977fa61.tar
gnu-guix-0df77274d1e1e143a54adfef96150b182977fa61.tar.gz
gnu: vulkan: Add spirv-headers.
* gnu/packages/vulkan.scm: Create file. (spirv-headers): New variable. * gnu/local.mk: Add vulkan.scm. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
new file mode 100644
index 0000000000..492457f68c
--- /dev/null
+++ b/gnu/packages/vulkan.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages vulkan)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages))
+
+(define-public spirv-headers
+ (let ((commit "98b01515724c428d0f0a5d01deffcce0f5f5e61c")
+ (revision "1"))
+ (package
+ (name "spirv-headers")
+ (version (string-append "0.0-" revision "." (string-take commit 9)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KhronosGroup/SPIRV-Headers")
+ (commit commit)))
+ (sha256
+ (base32
+ "15bknwkv3xwmjs3lmkp282a1wrp0da1b4lp45i4yiav04zmqygj2"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;; No tests
+ #:phases (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "cmake" "-E" "copy_directory"
+ "../source/include/spirv"
+ (string-append (assoc-ref outputs "out")
+ "/include/spirv"))))))))
+ (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
+ (synopsis "Machine-readable files from the SPIR-V Registry")
+ (description
+ "SPIRV-Headers is a repository containing machine-readable files from
+the SPIR-V Registry. This includes:
+@itemize
+@item Header files for various languages.
+@item JSON files describing the grammar for the SPIR-V core instruction set,
+and for the GLSL.std.450 extended instruction set.
+@item The XML registry file.
+@end itemize\n")
+ (license (license:x11-style
+ (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
+ commit "/LICENSE"))))))