summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-12-01 12:21:55 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-12-11 11:58:41 +0100
commit1ce6f33b0c085940af29dc17e0f64db0a1dbaa99 (patch)
treece6c377e3a31925e8d841d65187d1d9128e24934 /gnu/packages/vpn.scm
parent6c2e82bcb70f09dc324e980ef6d0b0be1546f0f5 (diff)
downloadgnu-guix-1ce6f33b0c085940af29dc17e0f64db0a1dbaa99.tar
gnu-guix-1ce6f33b0c085940af29dc17e0f64db0a1dbaa99.tar.gz
gnu: Add sshoot.
* gnu/packages/vpn.scm (sshoot): New variable.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index e11f669217..a32ac206ac 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -234,3 +234,31 @@ proxying. This makes it faster and more reliable than SSH's own tunneling and
port forwarding features. It can forward both TCP and UDP traffic, including
DNS domain name queries.")
(license license:lgpl2.0))) ; incorrectly identified as GPL in ‘setup.py’
+
+(define-public sshoot
+ (package
+ (name "sshoot")
+ (version "1.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32
+ "0a92lk8790dpp9j64vb6p4sazax0x3nby01lnfll7mxs1hx6n27q"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-argcomplete" ,python-argcomplete)
+ ("python-prettytable" ,python-prettytable)
+ ("python-pyyaml" ,python-pyyaml)))
+ ;; For tests only.
+ (native-inputs
+ `(("python-fixtures" ,python-fixtures)
+ ("python-pbr" ,python-pbr)
+ ("python-testtools" ,python-testtools)))
+ (home-page "https://bitbucket.org/ack/sshoot")
+ (synopsis "sshuttle VPN session manager")
+ (description "sshoot provides a command-line interface to manage multiple
+@command{sshuttle} virtual private networks. It supports flexible profiles
+with configuration options for most of @command{sshuttle}’s features.")
+ (license license:gpl3+)))