aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-23 03:42:12 -0400
committerLeo Famulari <leo@famulari.name>2017-07-23 03:42:12 -0400
commit6c1a317e29c45e85e3a0e050612cdefe470b100c (patch)
treee65dedf933090b1a9f8398655b3b20eba49fae96 /gnu/packages/vim.scm
parentb7158b767b7fd9f0379dfe08083c48a0cf0f3d50 (diff)
parent9478c05955643f8ff95dabccc1e42b20abb88049 (diff)
downloadgnu-guix-6c1a317e29c45e85e3a0e050612cdefe470b100c.tar
gnu-guix-6c1a317e29c45e85e3a0e050612cdefe470b100c.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 27c0b0da9c..f8c9761924 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -60,7 +60,7 @@
(define-public vim
(package
(name "vim")
- (version "8.0.0600")
+ (version "8.0.0727")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/vim/vim/archive/v"
@@ -68,7 +68,7 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1ifaj0lfzqn06snkcd83l58m9r6lg7lk3wspx71k5ycvypyfi67s"))))
+ "0hwqglpsk8qlp2rn6q9p35fxk88xixljk1yv42m3j01g3bgqg0gx"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -111,8 +111,20 @@ configuration files.")
(define-public vim-full
(package
+ ;; This package should share its source with Vim, but it doesn't
+ ;; build reliably, and we want to keep Vim up to date due to the
+ ;; frequency of important bug fixes.
(inherit vim)
(name "vim-full")
+ (version "8.0.0600")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/vim/vim/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ifaj0lfzqn06snkcd83l58m9r6lg7lk3wspx71k5ycvypyfi67s"))))
(arguments
`(#:configure-flags
(list (string-append "--with-lua-prefix="