summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-01 18:48:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-01 18:48:54 +0200
commitfb0b645658041c3061d2f70dc1a11a100f569217 (patch)
treefd2db14e40b95aec5bff2061a57be007d01bb707 /gnu/packages/vim.scm
parent37b82ccc390396a078351fd9f7b522cca275a8c9 (diff)
downloadgnu-guix-fb0b645658041c3061d2f70dc1a11a100f569217.tar
gnu-guix-fb0b645658041c3061d2f70dc1a11a100f569217.tar.gz
gnu: vim-fugitive: Update to 2.5.
* gnu/packages/vim.scm (vim-fugitive): Update to 2.5. [arguments]: Also install the autoload and ftdetect folders.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 28d20af023..ecce4e0ae6 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -459,7 +459,7 @@ trouble using them, because you do not have to remember each snippet name.")
(define-public vim-fugitive
(package
(name "vim-fugitive")
- (version "2.3")
+ (version "2.5")
(source
(origin
(method git-fetch)
@@ -469,7 +469,7 @@ trouble using them, because you do not have to remember each snippet name.")
(file-name (git-file-name name version))
(sha256
(base32
- "17s94a8g5z0lrs7yy4nyqyvp9ykys5ws2ar3m3c0bjsn0iazd7m3"))))
+ "17yz7gxn7a49jzndr4z5vnk1y4a6c22qss3mwxzmq4m46fni0k8q"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f
@@ -481,9 +481,13 @@ trouble using them, because you do not have to remember each snippet name.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(vimfiles (string-append out "/share/vim/vimfiles"))
+ (autoload (string-append vimfiles "/autoload"))
(doc (string-append vimfiles "/doc"))
+ (ftdetect (string-append vimfiles "/ftdetect"))
(plugin (string-append vimfiles "/plugin")))
+ (copy-recursively "autoload" autoload)
(copy-recursively "doc" doc)
+ (copy-recursively "ftdetect" ftdetect)
(copy-recursively "plugin" plugin)
#t))))))
(home-page "https://github.com/tpope/vim-fugitive")