summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-21 15:17:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-21 15:20:20 +0200
commita2aa746cfe38076b87d9cde2252904c0bddd9f9e (patch)
treedec28ddc6be854c7cd56bc9edea4668f415870fb /gnu/packages/video.scm
parent96cae1b48c12b7b5b4a68d86ac9d714cab2d9881 (diff)
downloadgnu-guix-a2aa746cfe38076b87d9cde2252904c0bddd9f9e.tar
gnu-guix-a2aa746cfe38076b87d9cde2252904c0bddd9f9e.tar.gz
gnu: python-waf: Use a proper directory structure.
Fixes <https://bugs.gnu.org/25634>. * gnu/packages/python.scm (python-waf): Replace custom 'install phase to install "waf" binary into the bin directory. Remove the 'wrap phase. * gnu/packages/video.scm (mpv)[arguments]: Adjust the 'setup-waf phase accordingly.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 94c5cf3a67..e9a49df787 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1180,7 +1180,8 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(add-before
'configure 'setup-waf
(lambda* (#:key inputs #:allow-other-keys)
- (copy-file (assoc-ref inputs "waf") "waf")
+ (let ((waf (assoc-ref inputs "waf")))
+ (copy-file (string-append waf "/bin/waf") "waf"))
(setenv "CC" "gcc")
#t)))
#:configure-flags (list "--enable-libmpv-shared"