summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-06-28 22:05:53 -0500
committerEric Bavier <bavier@member.fsf.org>2018-11-26 19:04:22 -0600
commit69a3fcc086f0582d82f3b2d19ad94e12c67070fa (patch)
tree9ea754688cf375d51c7cb4dd24f56df439a39d4a /gnu/packages/video.scm
parent579a9cdec7673d9007ef924bb345f42527aa0a72 (diff)
downloadgnu-guix-69a3fcc086f0582d82f3b2d19ad94e12c67070fa.tar
gnu-guix-69a3fcc086f0582d82f3b2d19ad94e12c67070fa.tar.gz
gnu: Add OpenShot.
* gnu/packages/video.scm (openshot-qt): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bc8e625d72..bf1f6d36fa 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3140,3 +3140,49 @@ create smoother and stable videos.")
editing library with a multi-threaded and feature rich video editing
API. It includes bindings for Python, Ruby, and other languages.")
(license license:lgpl3+)))
+
+(define-public openshot
+ (package
+ (name "openshot")
+ (version "2.4.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenShot/openshot-qt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qdw1mli4y9qhrnllnkaf6ydgw5vfvdb90chs4i679k0x0jyb9a2"))))
+ (build-system python-build-system)
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("libopenshot" ,libopenshot)
+ ("python" ,python)
+ ("python-pyqt" ,python-pyqt)
+ ("python-pyzmq" ,python-pyzmq)
+ ("python-requests" ,python-requests)
+ ("qtsvg" ,qtsvg)))
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ (delete 'build) ;install phase does all the work
+ (add-before 'install 'set-tmp-home
+ (lambda _
+ ;; src/classes/info.py "needs" to create several
+ ;; directories in $HOME when loaded during build
+ (setenv "HOME" "/tmp")
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/openshot-qt")
+ `("QT_PLUGIN_PATH" prefix
+ ,(list (string-append (assoc-ref inputs "qtsvg")
+ "/lib/qt5/plugins/")))))))))
+ (home-page "https://openshot.org")
+ (synopsis "Video editor")
+ (description "OpenShot takes your videos, photos, and music files and
+helps you create the film you have always dreamed of. Easily add sub-titles,
+transitions, and effects and then export your film to many common formats.")
+ (license license:gpl3+)))