summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 21:46:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:48 +0100
commit520b5d06a4e1c6b06d161a420a083616469b5131 (patch)
tree9768ef41c4e13d67a42e4df3fc9c74c4ec615da4 /gnu/packages/video.scm
parent97ef6df5ecec825712c1253551d5be1ab7d89b06 (diff)
downloadgnu-guix-520b5d06a4e1c6b06d161a420a083616469b5131.tar
gnu-guix-520b5d06a4e1c6b06d161a420a083616469b5131.tar.gz
gnu: mlt: Fetch sources from git.
* gnu/packages/video.scm (mlt)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a10551e41b..2b030fed7a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2004,13 +2004,14 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(name "mlt")
(version "6.10.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mltframework/mlt/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mltframework/mlt.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1zzdj1g3g24q6v8hd0v34lv0pkh37a13fhjpl44h1ffi00mz3577"))
+ "0ki86yslr5ywa6sz8pjrgd9a4rn2rr4mss2zkmqi7pq8prgsm1fr"))
(modules '((guix build utils)))
(snippet '(begin
;; As of glibc 2.26, <xlocale.h> no longer is.