summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-31 19:19:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-11-01 04:34:24 +0100
commit2ea678fabfb57b05652fa8e0afe8fb6b1000473f (patch)
treea5853bd377c2407c43717aefbb701ceb63aab5a0 /gnu/packages/video.scm
parent4fbcfc148264b1ad97706d366dbd94ce4e02e56d (diff)
downloadgnu-guix-2ea678fabfb57b05652fa8e0afe8fb6b1000473f.tar
gnu-guix-2ea678fabfb57b05652fa8e0afe8fb6b1000473f.tar.gz
gnu: motion: Don't use unstable tarball.
* gnu/packages/video.scm (motion)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 900198a7a7..2eb79a88ff 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2915,14 +2915,14 @@ It counts more than 100 plugins.")
(version "4.2")
(home-page "https://motion-project.github.io/")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/Motion-Project/motion/archive/"
- "release-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Motion-Project/motion.git")
+ (commit (string-append "release-" version))))
(sha256
(base32
- "1ad2zlz941lvb818g1nzlpcpbxgv0h05q164hafa805yqm7m1y3f"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "0c0q6dl4v561m5y8bp0c0h4p3s52fjgcdnsrrf5ygdi288d3rfxv"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf-wrapper)