summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2017-06-03 21:48:06 +0200
committerClément Lassieur <clement@lassieur.org>2017-06-04 10:11:29 +0200
commit0dff4dd98667037f94bd653ff003fc4395c58ca7 (patch)
tree249a16fdc3a085b306472ba4668ffd0c4eb5c227 /gnu/packages/video.scm
parent2aaa57294e1980795e0be6b28a40b95b280be1ba (diff)
downloadgnu-guix-0dff4dd98667037f94bd653ff003fc4395c58ca7.tar
gnu-guix-0dff4dd98667037f94bd653ff003fc4395c58ca7.tar.gz
gnu: Add libdvbpsi.
* gnu/packages/video.scm (libdvbpsi): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8b8140eb96..af05a40bf9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2207,3 +2207,24 @@ JPEG video, and several audio codecs. They can easily be extended to support
additional (audio and/or video) codecs, and can also be used to build basic
RTSP or SIP clients and servers.")
(license license:lgpl3+)))
+
+(define-public libdvbpsi
+ (package
+ (name "libdvbpsi")
+ (version "1.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.videolan.org/pub/libdvbpsi/"
+ version "/libdvbpsi-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0824r08kaspbrrg2dd5d46s475zb7j59brqkm2y6x3mdsnpng0yn"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.videolan.org/developers/libdvbpsi.html")
+ (synopsis "Library for decoding and generation of MPEG TS and DVB PSI
+tables")
+ (description "libdvbpsi is a simple library designed for decoding and
+generation of MPEG TS and DVB PSI tables according to standards ISO/IEC 13818s
+and ITU-T H.222.0.")
+ (license license:lgpl2.1)))