summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-21 06:43:40 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-21 15:02:49 +0100
commitdcb06ac9cf60b2d25b4a249a1b310b39bdf57d30 (patch)
treeb2970fe4ddae5e2adec6499f5f70ca0bb85f2140 /gnu/packages/version-control.scm
parent79f0561f43cc62dd332007cd847c0ad2870b3afc (diff)
downloadgnu-guix-dcb06ac9cf60b2d25b4a249a1b310b39bdf57d30.tar
gnu-guix-dcb06ac9cf60b2d25b4a249a1b310b39bdf57d30.tar.gz
gnu: shflags: Use the GNU-BUILD-SYSTEM.
The TRIVIAL-BUILD-SYSTEM doesn't really save any effort and is actually slightly longer. * gnu/packages/version-control.scm (shflags)[build-system: Use GNU-BUILD-SYSTEM. [arguments]: Adjust accordingly and prefer INSTALL-FILE over COPY-FILE.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm30
1 files changed, 12 insertions, 18 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4b99592a59..a1f5cb5585 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -645,27 +645,21 @@ default) of the repository.")
(sha256
(base32
"0zxw12haylaq60a335xlqcs4afw2zrgwqymmpw0m21r51w6irdmr"))))
- (build-system trivial-build-system)
+ (build-system gnu-build-system)
(native-inputs `(("tar" ,tar)
("gzip" ,gzip)))
(arguments
- `(#:modules ((guix build utils))
- #:builder (begin
- (use-modules (guix build utils))
- (let* ((source (assoc-ref %build-inputs "source"))
- (tar (assoc-ref %build-inputs "tar"))
- (gzip (assoc-ref %build-inputs "gzip"))
- (output (assoc-ref %outputs "out"))
- (srcdir (string-append output "/src")))
- (begin
- (setenv "PATH" (string-append gzip "/bin"))
- (system* (string-append tar "/bin/tar") "xzf"
- source)
- (chdir ,(string-append name "-" version))
- (mkdir-p srcdir)
- (copy-file "src/shflags"
- (string-append srcdir "/shflags"))
- #t)))))
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; nothing to configure
+ (delete 'build) ; nothing to build
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (src (string-append out "/src")))
+ (install-file "src/shflags" src)
+ #t))))))
(home-page "https://github.com/kward/shflags")
(synopsis "Command-line flags library for shell scripts")
(description