summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-15 15:45:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-15 20:10:22 +0200
commit6ae35fea74002811bef8badca0abce0a771b2e19 (patch)
treedee3902398f18b4f067bb8191d9b119596422b6c /gnu/packages/version-control.scm
parenta1c86d1db4ba329de6dbbe480b3b9061c5c33a4d (diff)
downloadgnu-guix-6ae35fea74002811bef8badca0abce0a771b2e19.tar
gnu-guix-6ae35fea74002811bef8badca0abce0a771b2e19.tar.gz
gnu: cvs-fast-export: Update to 1.44.
* gnu/packages/version-control.scm (cvs-fast-export): Update to 1.44. [arguments]: Add ‘fix-setpython-PATH’ phase to do just that. Remove obsolete python3 work-around from ‘remove-optimizations’ phase.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 97e64a7cbc..1410e0da19 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1262,27 +1262,32 @@ RCS, PRCS, and Aegis packages.")
(define-public cvs-fast-export
(package
(name "cvs-fast-export")
- (version "1.43")
+ (version "1.44")
(source (origin
(method url-fetch)
(uri (string-append "http://www.catb.org/~esr/"
name "/" name "-" version ".tar.gz"))
(sha256
(base32
- "17xp5q4cxmd6z0ii1fdr4j1djb9mz1qv7hzr6fawdapjzahi65m3"))))
+ "1l7hlys4vw4zk4ikdjiig5vzgv5dv48mbm8bdqgvgkyyxb2j0dm0"))))
(build-system gnu-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-before 'check 'fix-setpython-PATH
+ (lambda _
+ ;; The Makefile does try to add the current working directory to
+ ;; $PATH, but this fails for some reason in 1.44. Hack around it.
+ (substitute* "tests/Makefile"
+ (("setpython" command)
+ (string-append "./" command)))
+ #t))
(add-after 'unpack 'remove-optimizations
(lambda _
;; Don't optimize for a specific processor architecture.
(substitute* "Makefile"
(("CFLAGS \\+= -march=native") ""))
- ;; This code runs with Python2 or Python3
- (substitute* "cvsreduce"
- (("python3") "python"))
#t)))
#:parallel-build? #f ; parallel a2x commands fail spectacularly
#:make-flags