summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-09-18 12:18:23 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-09-19 09:07:12 +0200
commit1cfcb841eddbe6b2bfed6dfaad6bcebff66e7a16 (patch)
treeaa5a6c830094225dce8cd1d03e4b8bb9fb5611be /gnu/packages/version-control.scm
parent20f8d73face564deec2f21130fb465c8c3d9a8e9 (diff)
downloadgnu-guix-1cfcb841eddbe6b2bfed6dfaad6bcebff66e7a16.tar
gnu-guix-1cfcb841eddbe6b2bfed6dfaad6bcebff66e7a16.tar.gz
gnu: git-credential-netrc: Add Git.pm to PERL5LIB.
* gnu/packages/version-control.scm (git)[credential-netrc]: Add Git.pm to PERL5LIB.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3774961786..58c870df5a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -309,6 +309,13 @@ as well as the classic centralized workflow.")
(let* ((netrc (assoc-ref outputs "credential-netrc")))
(install-file "contrib/credential/netrc/git-credential-netrc"
(string-append netrc "/bin"))
+ ;; Previously, Git.pm was automatically found by netrc.
+ ;; Perl 5.26 changed how it locates modules so that @INC no
+ ;; longer includes the current working directory (the Perl
+ ;; community calls this "dotless @INC").
+ (wrap-program (string-append netrc "/bin/git-credential-netrc")
+ `("PERL5LIB" ":" prefix
+ (,(string-append (assoc-ref outputs "out") "/share/perl5"))))
#t)))
(add-after 'install 'split
(lambda* (#:key inputs outputs #:allow-other-keys)