aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/uucp.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
commit1c055d72585bd075e20ad0b41942d501d0b38656 (patch)
tree7baf50e22fb5f6c6d4b2fa7197596f68298eb691 /gnu/packages/uucp.scm
parent565e24c4e4710a5b81cce5cfb619b3e474e7f65c (diff)
parentffb4da7ad5c0e9cc969e0e47a3b8f4d2eba4d6f3 (diff)
downloadgnu-guix-1c055d72585bd075e20ad0b41942d501d0b38656.tar
gnu-guix-1c055d72585bd075e20ad0b41942d501d0b38656.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/uucp.scm')
-rw-r--r--gnu/packages/uucp.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/uucp.scm b/gnu/packages/uucp.scm
index 7bfe76365f..f5d9c70052 100644
--- a/gnu/packages/uucp.scm
+++ b/gnu/packages/uucp.scm
@@ -35,18 +35,18 @@
"0b5nhl9vvif1w3wdipjsk8ckw49jj1w85xw1mmqi3zbcpazia306"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The old 'configure' script doesn't support the arguments
- ;; that we pass by default.
- (setenv "CONFIG_SHELL" (which "sh"))
- (let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--infodir=" out
- "/share/info")))))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The old 'configure' script doesn't support the arguments
+ ;; that we pass by default.
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--infodir=" out
+ "/share/info")))))))))
(home-page "https://www.gnu.org/software/uucp/uucp.html")
(synopsis "UUCP protocol implementation")
(description