summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-06 15:56:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-06 15:56:24 +0200
commit12bd588346f8b2fb3709acfe0ee89d153da2db34 (patch)
tree459d8eb13a0508170ba462fe61a8b45fb55ea79f /gnu/packages/syncthing.scm
parent7d5adf013127c89826e9fbe9f1a67265b3538609 (diff)
parent8e020519b45bbdb9403164bd4403f2465bac99ad (diff)
downloadgnu-guix-12bd588346f8b2fb3709acfe0ee89d153da2db34.tar
gnu-guix-12bd588346f8b2fb3709acfe0ee89d153da2db34.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 0a90610ecb..b650bedf25 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -29,7 +29,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "0.14.46")
+ (version "0.14.47")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -37,7 +37,7 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "0h5b2mp0li0qzrz3wggzavdfqfaz9b79hx6wds84ya2i9maw80cl"))
+ "1wz6cwq3la5676z1c20sh4fykmjwhs410xzcnb2jfyzaldf57cwj"))
(modules '((guix build utils)))
;; Delete bundled ("vendored") free software source code.
(snippet '(begin
@@ -145,7 +145,7 @@
("go-golang-org-x-net-union" ,(go-golang-org-x-net-union))
("go-golang-org-x-text" ,(go-golang-org-x-text-union))
("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)
- ("go-github-com-zillode-notify" ,go-github-com-zillode-notify)
+ ("go-github-com-syncthing-notify" ,go-github-com-syncthing-notify)
;; For tests
("go-github-com-d4l3k-messagediff" ,go-github-com-d4l3k-messagediff)))
(synopsis "Decentralized continuous file system synchronization")
@@ -507,7 +507,10 @@ address of the default LAN gateway.")
"056dkgxrqjj5r18bnc3knlpgdz5p3yvp12y4y978hnsfhwaqvbjz"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/kardianos/osext"))
+ `(#:import-path "github.com/kardianos/osext"
+ ;; The tests are flaky:
+ ;; <https://github.com/kardianos/osext/issues/21>
+ #:tests? #f))
(synopsis "Find the running executable")
(description "Osext provides a method for finding the current executable
file that is running. This can be used for upgrading the current executable or
@@ -910,7 +913,6 @@ libraries are in the same directory.")
(define* (go-golang-org-x-net-union #:optional
(packages (list go-golang-org-x-net-ipv4
go-golang-org-x-net-bpf
- go-golang-org-x-net-context
go-golang-org-x-net-ipv6
go-golang-org-x-net-proxy
go-golang-org-x-net-internal-iana)))
@@ -1111,30 +1113,30 @@ using sh's word-splitting rules.")
(home-page "https://github.com/kballard/go-shellquote")
(license expat))))
-(define-public go-github-com-zillode-notify
- (let ((commit "53dd6873a851fc377c87d82f994b1fecdf25aadb")
- (revision "3"))
+(define-public go-github-com-syncthing-notify
+ (let ((commit "b9ceffc925039c77cd9e0d38f248279ccc4399e2")
+ (revision "0"))
(package
- (name "go-github-com-zillode-notify")
+ (name "go-github-com-syncthing-notify")
(version (git-version "0.0.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/calmh/notify")
+ (url "https://github.com/syncthing/notify")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "0ar6mj6s91y7hc5gdp88lz3i7xi29cqkx9f090xj899ir21a8djn"))))
+ "1scha9b2r35bvqzqx86sarzjxf72ywvj3g6n9pm3xq4i4xzpylxf"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/Zillode/notify"))
+ '(#:import-path "github.com/syncthing/notify"))
(propagated-inputs
`(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
(synopsis "File system event notification library")
(description "This package provides @code{notify}, a file system event
notification library in Go.")
- (home-page "https://github.com/zillode/notify")
+ (home-page "https://github.com/syncthing/notify")
(license expat))))
(define-public go-github-com-beorn7-perks-quantile