summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-06-01 17:10:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-02 13:39:06 +0200
commitd22546cf80696719cfb76aec2ffdf44863be3fbc (patch)
tree59dcf27912e9cb2e926afacd97688e5e9599bf57 /gnu/packages/statistics.scm
parentd5452aa201a2f297e503658576ee99a7c070787c (diff)
downloadgnu-guix-d22546cf80696719cfb76aec2ffdf44863be3fbc.tar
gnu-guix-d22546cf80696719cfb76aec2ffdf44863be3fbc.tar.gz
gnu: r-minimal: Update to 3.5.0.
* gnu/packages/statistics.scm (r-with-tests): New variable derived from r-minimal; update to 3.5.0. [arguments]: Build recommended packages. (r-minimal): Inherit from r-with-tests. [arguments]: Disable recommended packages and tests.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm29
1 files changed, 20 insertions, 9 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7d5c552a3e..7a6b674a1d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -113,10 +113,10 @@ be output in text, PostScript, PDF or HTML.")
;; Update this package together with the set of recommended packages: r-boot,
;; r-class, r-cluster, r-codetools, r-foreign, r-kernsmooth, r-lattice,
;; r-mass, r-matrix, r-mgcv, r-nlme, r-nnet, r-rpart, r-spatial, r-survival.
-(define-public r-minimal
+(define r-with-tests
(package
- (name "r-minimal")
- (version "3.4.4")
+ (name "r-with-tests")
+ (version "3.5.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -124,7 +124,7 @@ be output in text, PostScript, PDF or HTML.")
version ".tar.gz"))
(sha256
(base32
- "0dq3jsnwsb5j3fhl0wi3p5ycv8avf8s5j1y4ap3d2mkjmcppvsdk"))))
+ "0w38865laqg28cdhikxdxhx4rfp0kgcn72gakwypsy91br9ja5zx"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,tzdata-for-tests)
@@ -217,11 +217,9 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(add-after 'build 'install-info
(lambda _ (zero? (system* "make" "install-info")))))
#:configure-flags
- `(;; Do not build the recommended packages. The build system creates
- ;; random temporary directories and embeds their names in some
- ;; package files. We build these packages with the r-build-system
- ;; instead.
- "--without-recommended-packages"
+ `(;; We build the recommended packages here, because they are needed in
+ ;; order to run the test suite. We disable them in the r-minimal
+ ;; package.
"--with-cairo"
"--with-blas=-lopenblas"
"--with-libpng"
@@ -292,6 +290,19 @@ publication-quality data plots. A large amount of 3rd-party packages are
available, greatly increasing its breadth and scope.")
(license license:gpl3+)))
+(define-public r-minimal
+ (package (inherit r-with-tests)
+ (name "r-minimal")
+ (arguments
+ `(#:tests? #f
+ ,@(substitute-keyword-arguments (package-arguments r-with-tests)
+ ((#:configure-flags flags)
+ ;; Do not build the recommended packages. The build system creates
+ ;; random temporary directories and embeds their names in some
+ ;; package files. We build these packages with the r-build-system
+ ;; instead.
+ `(cons "--without-recommended-packages" ,flags)))))))
+
(define-public rmath-standalone
(package (inherit r-minimal)
(name "rmath-standalone")